NTA - Invoice Generation – Incident details

All systems operational

Invoice Generation

Resolved
Major outage
Started about 1 month agoLasted about 5 hours
Updates
  • Resolved
    Resolved

    All 01/09/2025 invoices have now been generated. Please go to Reports > Invoices on the portal. Thank you for your patience.

  • Identified
    Identified

    The invoice generation has been restarted

  • Investigating
    Investigating

    We are currently investigating a fault with invoice generation on ntalk.co.uk. All invoices are now being regenerated. This could take up to the end of the business day. Any invoices dated 01/09/2025 will be replaced with a new invoice.
    Please email accounts@nta.co.uk for any questions. Updates will be available on this status page when available.
    We apologise for any inconvenience caused.