Planned Maintenance 17 May 2023
Scheduled for 17 May 2023 at 8:00 PM – 11:00 PM
Completed
17 May 2023 at 11:00 PMCompleted
17 May 2023 at 11:00 PMMaintenance has completed successfully
In progress
17 May 2023 at 8:00 PMIn progress
17 May 2023 at 8:00 PMMaintenance is now in progress
Planned
17 May 2023 at 8:00 PMPlanned
17 May 2023 at 8:00 PMWednesday, 17 May 2023 between 21:00 - 00:00
Work is required in order to improve our systems.
Wednesday night between 21:00 - 00:00 we will be carrying out systems updates.
This maintenance is classed as at low risk.