All systems operational

Mobex on Android

Resolved
Operational
Started 4 months ago Lasted about 23 hours

Affected

Secondary Services
MobeX Mobile
Updates
  • Resolved
    Resolved

    The incident has now been resolved and the app is available on Playstore now

  • Identified
    Identified

    Android users of Mobex may see a notification on their devices that the app is harmful to their device and to uninstall it. Please advise them not to do so as it is an error on Google's part with their certification. We are working with Google to get a quick resolution and apologise for any confusion this may be causing