All systems operational

New Mobex+ users

Resolved
Operational
Started 6 months ago Lasted 1 day

Affected

Secondary Services
MobeX Mobile
Updates
  • Resolved
    Update

    MobeX + has been relisted on the Google Play Store now, so should be available for download again; existing users should no longer see any warnings.

    We apologise for any inconvenience caused.

  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Important Notice: MobeX+ Issue Affecting Android Users

    Unfortunately, Google has decided to remove MobeX+ from the PlayStore, as they now say we do not disclose the use of Contact's images.

    The reason MobeX+ may require access to the device's Contacts and its images is to provide features such as displaying contact names for incoming and outgoing calls, facilitating easy call log management, and improving the overall user experience. This permission enables us to enhance the functionality of the app by seamlessly integrating with your existing contacts. We also make use of the contact's images to allow users to easily identify who is calling and to whom they want to call. Please be assured that we only access and use this information for the purposes described in this Privacy Policy.

    Whilst we communicate with Google to restore the MobeX+ application, we regret to inform you that the application cannot currently be downloaded from the Play Store. However, if you currently have the app downloaded, you can continue to use it as normal. Google may send you messages such as this App is dangerous but this is not the case and there is no need to uninstall.

    We will continue to update our status page and hope to have a resolution soon.

    We apologise for any inconvenience caused.