[Resolved] Calling Support

Started on 09 March 2021 at 12:44 PM. Resolved after about 2 hours

Affected

Inbound Calls
  • Investigating
    09 March 2021 at 12:44 PM

    Please be aware that calls are not connecting to number 01708 393939.

    Please call 01708 320000 to connect to support.

  • Resolved
    09 March 2021 at 2:52 PM

    Our 01708393939 support number has resumed service. This number is hosted off our network for redundancy purposes and the upstream carrier was experiencing network issues.