[Resolved] Inbound Queue Calls not connecting

Started on 01 February 2021 at 1:44 PM. Resolved after about 2 hours

Affected

Inbound Calls
  • Investigating
    01 February 2021 at 1:44 PM

    We are currently investigating this incident.

  • Monitoring
    01 February 2021 at 2:05 PM

    We see some agents stuck on calls that happened during the issue which are now being cleared. Please report any issues you are still experiencing to our support team.

  • Resolved
    01 February 2021 at 4:03 PM

    We will continue to monitor and investigate this incident internally but expect no further disruption.