[Resolved] Inbound Call issues to queues

Started on 22 January 2021 at 9:01 AM. Resolved after about 2 hours

Affected

Inbound Calls
  • Investigating
    22 January 2021 at 9:01 AM

    We are currently investigating an incident where calls to queues are not answered correctly.

  • Monitoring
    22 January 2021 at 9:06 AM

    We implemented a fix and currently monitoring the result.

  • Monitoring
    22 January 2021 at 9:45 AM

    Old queue calls are currently still showing as active and therefore new calls are not connecting. We are aware of this issue and working to resolve it.

  • Monitoring
    22 January 2021 at 10:10 AM

    We are currently monitoring the situation and clearing old calls.

  • Monitoring
    22 January 2021 at 10:31 AM

    If your customer is affected by this queue issue, please ask them to bear with us. We are clearing old calls which will allow new inbound calls to the agents.

  • Monitoring
    22 January 2021 at 11:00 AM

    We're wrapping up finishing old calls, not much longer now.

  • Resolved
    22 January 2021 at 11:14 AM

    We believe this issue has now been fully resolved. We will keep monitoring the situation and update our status page accordingly. Thank you for your patients and sorry for the inconvenience caused.