[Resolved] Loss of service

Started on 19 January 2021 at 10:30 AM. Resolved after 35 minutes

Affected

Inbound Calls
Outbound Calls
Web Interface
  • Investigating
    19 January 2021 at 10:30 AM

    We're currently experiencing technical difficulties across our network.

  • Resolved
    19 January 2021 at 11:05 AM

    We just resolved the issue!