Planned maintenance 02/04/26
Scheduled for 02 April 2026 at 9:00 PM – 03 April 2026 at 4:00 AM
Affects
Inbound Calls
Under maintenance from 9:00 PM to 4:00 AM
Outbound Calls
Under maintenance from 9:00 PM to 4:00 AM
Completed
03 April 2026 at 4:00 AMCompleted
03 April 2026 at 4:00 AMMaintenance has completed successfully
In progress
02 April 2026 at 9:00 PMIn progress
02 April 2026 at 9:00 PMMaintenance is now in progress
Planned
02 April 2026 at 9:00 PMPlanned
02 April 2026 at 9:00 PMOne of our suppliers is performing maintenance on their core network.
The maintenance will be carried out on Thursday 2nd of April from 10pm to 5am.
There may be disruption to our service during the maintenance window.
This maintenance is classed as at low risk.