All systems operational

Planned Maintenance 13 April 2024

Completed
Scheduled for 13 April 2024 at 9:00 PM – 11:00 PM

Affects

Inbound Calls
Outbound Calls
Busy Lamps
Secondary Services
MobeX Mobile
MobeX Softphone
Updates
  • Completed
    13 April 2024 at 11:00 PM
    Completed
    13 April 2024 at 11:00 PM
    Maintenance has completed successfully
  • In progress
    13 April 2024 at 9:00 PM
    In progress
    13 April 2024 at 9:00 PM
    Maintenance is now in progress
  • Planned
    13 April 2024 at 9:00 PM
    Planned
    13 April 2024 at 9:00 PM

    On Saturday 13th April 2024 from 10:00pm to midnight, essential system maintenance is scheduled to enhance our systems' performance.

    During this upgrade, we will be improving the system reliability following the issues identified on 25th March 2024. The enhancements will not only optimise performance but also ensure swift recovery in the event of future complications.

    This maintenance is classed as medium risk.