All systems operational

Planned Maintenance 17 February 2024

Completed
Scheduled for 17 February 2024 at 10:00 AM – 12:00 PM

Affects

Inbound Calls
Outbound Calls
Busy Lamps
Secondary Services
MobeX Mobile
MobeX Softphone
Updates
  • Completed
    17 February 2024 at 12:00 PM
    Completed
    17 February 2024 at 12:00 PM
    Maintenance has completed successfully
  • In progress
    17 February 2024 at 10:00 AM
    In progress
    17 February 2024 at 10:00 AM
    Maintenance is now in progress
  • Planned
    17 February 2024 at 10:00 AM
    Planned
    17 February 2024 at 10:00 AM

    Saturday, 17 February 2024 between 22:00 - 00:00

    Work is required in order to improve our systems.

    Saturday night between 22:00 - 00:00 we will be carrying out essential upgrade work.

    This maintenance is classed as at low risk.