All systems operational

Mobex+ on Android

Resolved
Operational
Started 4 months ago Lasted about 22 hours

Affected

Secondary Services
MobeX Mobile
Updates
  • Resolved
    Resolved

    This incident has been resolved and Mobex+ is now available in Play Store.

  • Identified
    Identified

    Google has again deemed some of the components for the certification of Mobex+ on Android to be invalid and you may get a security notification, this is despite them agreeing it was safe back in July 2023. The app is perfectly safe to use but at the moment you will not be able to download it from the Play Store. We are continuing to work on a fix for this incident and apologise for any inconvenience it may cause you.